Differences between revisions 1 and 7 (spanning 6 versions)
Revision 1 as of 2008-03-03 13:07:10
Size: 2066
Comment:
Revision 7 as of 2008-03-04 08:00:35
Size: 2151
Comment:
Deletions are marked like this. Additions are marked like this.
Line 9: Line 9:
* PacsEng_Name : observations with no_pointing requests * `PacsEng_Name` : observations with no_pointing requests
Line 11: Line 11:
* PacsCal_Name : observations on sky (with a real pointing request) * `PacsCal_Name` : observations on sky (with a real pointing request)
Line 15: Line 15:
No "_OBS" is required because by definition a PacsEng or a PacsCal is an observations No "_OBS" is required because by definition a `PacsEng` or a `PacsCal` scrpt is an observations
Line 17: Line 17:
2- there is no recommandation for naming procedures and bluiding blocks. BUT for consistency, and for identification in the database (both for us and the HSC): PACS_Name or Pacs_Name 2- there is no recommandation for naming procedures and bluiding blocks. BUT for consistency, and for identification in the database (both for us and the HSC): `PACS_Name` or `Pacs_Name`
Line 24: Line 24:
The CUS top level scrips: PacsEng and PacsCal should be kept as ascetic as possible: i.e. they should contains as little as possible. All computations, logic and checks should be self contained in procedures and building blocks. The idea is to keep a modular structure of the scripts. The CUS top level scrips: PacsEng and PacsCal should be kept as ascetic as possible: i.e. they should contains as little as possible. All computations, logic and checks should be self contained in procedures and building blocks. The idea is to keep a modular structure of the scripts. ''This is a bad naming example for the procedures though''
Line 28: Line 28:
PacsCal_WaveCalNoChop
     calls: WaveCalNoChop
["PacsCal_WaveCalNoChop"]
     calls: `WaveCalNoChop`
Line 33: Line 33:
PacsCal_WaveCalChop
    calls: Pacs_HardLimitsCheck, PacsSpecSlewCal, WaveCalChop, ["SPEC_aot_epilogue"]
["PacsCal_WaveCalChop"]
    calls: `Pacs_HardLimitsCheck, PacsSpecSlewCal, WaveCalChop, ["SPEC_aot_epilogue"]`
Line 43: Line 43:
["CONF_phot_fltw_OBS"] has been translated into ["PacsEng_CONF_fltw"] calling simply ["CONF_phot_fltw"] ["CONF_phot_fltw_OBS"] has been translated into ["PacsEng_CONF_fltw"] calling simply `CONF_phot_fltw`
Line 47: Line 47:
["PACS_Spec_Gra_Diaghk_Setup_OBS"] has been translated into ["PacsEng_Spec_Gra_Diaghk_Setup"] calling ["PACS_Spec_Gra_Diaghk_Setup"](diag_hk_period) ["PACS_Spec_Gra_Diaghk_Setup_OBS"] has been translated into ["PacsEng_Spec_Gra_Diaghk_Setup"] calling `PACS_Spec_Gra_Diaghk_Setup(diag_hk_period)`

Naming Conventions and Logic of PV/commissioning phase CUS scripts

This page will describe the new Naming Conventions and the Logic used for writing PV/Commissioning phase scripts

Naming Conventions

1- observations should be called either:

* PacsEng_Name : observations with no_pointing requests

* PacsCal_Name : observations on sky (with a real pointing request)

Rem: "underscore" can be used as well within the name.

No "_OBS" is required because by definition a PacsEng or a PacsCal scrpt is an observations

2- there is no recommandation for naming procedures and bluiding blocks. BUT for consistency, and for identification in the database (both for us and the HSC): PACS_Name or Pacs_Name

3- By defaults, exporting scripts form CUS creates a .txt ascii file, please keep this extension.

Logic for CUS scripts defined for the PV/Commissioning phase

The CUS top level scrips: PacsEng and PacsCal should be kept as ascetic as possible: i.e. they should contains as little as possible. All computations, logic and checks should be self contained in procedures and building blocks. The idea is to keep a modular structure of the scripts. This is a bad naming example for the procedures though

e.g.

["PacsCal_WaveCalNoChop"]

  • calls: WaveCalNoChop

or.

["PacsCal_WaveCalChop"]

  • calls: Pacs_HardLimitsCheck, PacsSpecSlewCal, WaveCalChop, ["SPEC_aot_epilogue"]

IST/SFT translation

The IST/SFT scripts have been thus translated as follow:

* scripts including only a simple proc/block call: e.g.

["CONF_phot_fltw_OBS"] has been translated into ["PacsEng_CONF_fltw"] calling simply CONF_phot_fltw

or.

["PACS_Spec_Gra_Diaghk_Setup_OBS"] has been translated into ["PacsEng_Spec_Gra_Diaghk_Setup"] calling PACS_Spec_Gra_Diaghk_Setup(diag_hk_period)

* scripts which had a more complex structure, e.g.

["PACS_Chopper_SFT_Warm_OpenLoop_OBS"] was too complex to be translated directly into a PV phase script. So it was modified to become a procedure and the be called as such by ["PacsEng_Chopper_SFT_Warm_OpenLoop"]

Herschel: PACS/CUSscripts (last edited 2009-07-15 14:32:37 by localhost)